Home / Featured / blockUI requires jQuery v1.2.3 or later! You are using v1.10.2
blockUI requires jQuery v1.2.3 or later! You are using v1.10.2

blockUI requires jQuery v1.2.3 or later! You are using v1.10.2

WordPress 3.6 jQuery Error! Don’t panic, everything will be just fine in just a moment. You don’t have to worry about downgrading either.

If you are getting this error “blockUI requires jQuery v1.2.3 or later! You are using v1.10.2″ Let me explain what’s going on and how to fix the problem.

Basically your theme or plugins are using an older versions of jQuery and the developers need to update them.

We are going to get in to how to find where the problems lie in just a moment but for now here is a solution that made a quick fix for me.

I installed and activated jQuery Updater and it fixed the issue without any configuration. It actually has none so it made it really simple.

You can find the jQuery Updater download at WordPress.org for free here: http://wordpress.org/plugins/jquery-updater/

This solution worked for me but it may not work for you depending on what plugins or theme you have activated.

Lets get in to pin pointing the problem so we can actually fix it without a band-aid. Extra clutter in your plugin directory of your site is never good. Remember the more you make your visitors browser call for different files and make your server serve extra files the longer your web page takes to load.

When impatient visitors come to your site many will not wait past the 3 second mark before leaving your site.

Lets move forward and clean this issue up.

Lets start with your theme. Out of all the sites we had a problem with this was the biggest culprit.

If you have installed and activated jQuery Updater go ahead and deactivate it temporarily. Go to the front end of your site and you will see the error.

Now go to the admin panel and change your theme to Twenty Thirteen.

Navigate to the front end again to see if the error is gone, most likely it is.

If so change your theme back to the theme you normally use, activate jQuery Updater.

Now you can contact the developer of your theme to tell them about the issue. You might want to ask if they have an ETA on an update and if they can send you an email when it’s available.

If the error still occurs after the steps above, you need to deactivate plugins one by one until the error goes away. Once it does you have pin pointed the plugin causing the issue.

Then follow the same steps in contacting the developers about the issue/s.

I hoped this helped, if you need any help I’m a comment away.


About Ron Smart


  1. I tried the updater plugin, but did not solve my problem of not being able to preview posts. I had disabled a plug in that caused the JQuery error msg with the 3.6 update, but now having this problem, Sigh…how do I downgrade WP?

  2. Updater worked for me w/ a woocommerce site. Thanks a lot Ron.

  3. had same issue with :error: blockUI requires jQuery v1.2.3 or later! You are using v1.10.2

    fix it with updater;http://wordpress.org/plugins/jquery-updater/

    Thanks Ron worked instantly with my woo commerce theme.

  4. I had this exact error and it was caused by an outdated version of the Sidebar Login plugin, which incorporated an outdated version of the blockUI jQuery library (http://www.malsup.com/jquery/block/). Updating either should resolve the issue. To be clear your jQuery *probably* isn’t outdated, there was just a problem with the code blockUI used to detect the version.

  5. The updated worked for me as well. And it was a woocommerce site also. I now have to check if WOO has an update available. None are showing through the control panel. But there may be an update available on their website.
    Thank for the info!

    • Hi Steven, did woothemes do the updates? Glad it worked out in the mean time.

      • There are updates available. They do not show in my Dashboard though. I am not sure why not. But I will have to update manually and have not gotten around to it just yet. Woo is pretty good about these things and I would imagine that they were proactive on this. The last update for their Canvas theme was on July 2, 2013 so hopefully they have already updated. I have a much older version currently running on this particular site.

  6. I don’t see how this is a “fix”? The error message seems spurious, as if the version check is performing a simple string comparison, rather than exploding the version numbers properly. (Stringwise “1.1zzzz” IS less than “1.2zz”.)After all 1.10.2 is already way later than 1.2.3. The fix is for blockUI (whatever that is – not being a WP ninja I don’t know) to do a proper version comparison.

  7. The jquery updater worked a treat! Thanks a ton!!

  8. The culprit for me was the All In One Event Calendar plugin by Timely. I felt pretty confident it wasn’t my theme as I use the Genesis Platform and had upgraded to their 2.0 with the WordPress 3.6 so I started going through the plugins. When I deactivated the All In One Event Calendar plugin the error went away. I then updated the plugin and reactivated but it still came back. Deactivated again and it went away. I really like that plugin so I will keep an eye out for another update from them. Thanks for this post putting me on the right track!

  9. jQuery Updater, it works, thanks a lot!

  10. Exactly what Gulraj Rijhwani said – it’s not due to outdated jQuery, but rather the version check isn’t distinguishing between v1.1 and v1.10 on some plugins (and maybe some themes). I’ve found this in a couple of plugins so far. Found a temporary fix for Comprehensive Google Map Plugin here (http://wordpress.org/support/topic/jquerey-error-after-wordpress-36-update) – now I’m trying to find the version check code to apply this to Time.ly’s All-In-One Event Calendar.

    • Hi Kristin, I hope all is well. I definitely agree it’s not a fix nor a outdated jQuery problem. This was not the point and there are far to many plugin and theme variations to tackle in one article. Developers should be tackling this where the average user shouldn’t. The developers have early access to releases as does anyone else but the developers really should be the ones fixing these issues as the average users could cause other problems in the code.

      The solution you found however is perfect, great find.

      For anyone reading this you still want to go through the trouble shooting steps to make sure you don’t have additional plugins causing this issue and always notify the developer so they can fix the problem officially.

  11. Hi Ron.

    Is there any way to fix this issue manually?
    How about to updated jQuery file manually?

  12. shockingly it seems to work. Thank you very much. What would i do without the internet?

  13. Thanks so much for taking the time to post this. It worked perfectly for me and I passed it on to my website clients as well.

  14. Sovle the problem with the steps you offered! Thanks!

  15. Thanks a lot for u’r solution. really i am happy now. i solved my problem by u’r suggestion. i uploaded jquery updater & installed it as wordpress plugin then problem was solved.

    thanks again

  16. Thank you so much! I really had a panic moment for a minute. Googled error and your post was the first one. Didn´t waste any time.

  17. I deactivate all plug-ins and it did not solve the error. I even choose 2014 theme and it didn’t help either.

    Anything else I can do?


  18. Hello can you letting me know which web host you’re working with?
    I’ve loaded your blog in 3 different browsers and I must express this
    blog loads a lot quicker then most. Can you recommend
    a good hosting provider at a reasonable price? Thanks,
    I appreciate it!

    • Hey bud hope all is well, sorry for the late reply. I have been through many hosts which has been kind of frustrating to say the least. The last year I’ve been super happy with inmotion hosting here is my affiliate link http://ronsmart.com/pf56

      I have not yet moved this site because I have been super busy and usually my own stuff gets pushed aside. My money sites are on inmotion and I use their VPS service. Their business class is great as well if you are on a budget. If you get the VPS you might want to look in to the managed service. The really do an awesome job in installing any modules I need and keeping everything up to date and secure. Not one problem at all with their service I highly recommend them.

      One of these days I’ll get back to this site and give you guys some good info. Sorry I am such a slacker these days ;)

Leave a Reply

Your email address will not be published. Required fields are marked *


You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

Scroll To Top